Saját ZX Net

ZX Spectrum hardverek és illesztők...
kpbendi
Hozzászólások: 79
Csatlakozott: 2012.01.09. 14:42

Saját ZX Net

Hozzászólás Szerző: kpbendi » 2020.08.08. 17:33

Sziasztok!

Végre kezd összeállni a saját kis zx netem.
zxtwins.jpg
Két spectrum 48K, zx interface 1, microdrive vDrive-al és két 8" monitor.
A gépek elég komoly szervizelésen estek át: recap, composite mod, video tranzisztorok, 7805 cserélve MuRata regulatorra és a zx interface miatt új z80 cpu mindkettőben. Az egyik gép hibás táp miatt elszállt így ráadásként rom-ot és ula-t is kellett cserélni (nebula-ra). Alig maradt szegényekben valami az eredeti alkatrészekből, de végre működnek.

1. probléma:
A monitorokon van ugyan composite bemenet, de a képminőség hulladék, az 1024x768-as képernyőkön a kép elmosódott és egy picit fel-le remeg.
Két konverterrel próbálkoztam:
converters.jpg
Az egyik composite to HDMI, ez használhatatlan, a kép elcsúszik kb. a képernyő egyharmadáig.
A másik composite to VGA, ez teljesen jó képet ad a kis monitoron, mondhatni tökéletes. Van viszont egy idegesítő tulajdonsága: ha a kép sötét, akkor automatikusan levesz a teljes fényerőből. Pl. border 0-val a világos színek fényessége is annyit csökken, mint a bright 0 és bright 1 közötti különbség. Ha visszaállítom border 7-re, akkor a fényerő is visszajön.
Ez azért gond, mert a legtöbb játék kerete fekete és így állandóan matatni kell a fényességet és a kontrasztot, hogy egyáltalán lássak valami, ha meg visszamegyek basicbe, állíthatom át megint.
Ráadásul nem tudom eldönteni, hogy a spectrum csinálja-e, vagy a konverter.

Tapasztalat már valaki hasonlót?
Ha a spektrum variálja a videó jelszintjét a bordertől függően, és azért esik le a fényerő, akkor van valami megoldás a videó jelszint stabilizálására?
Ha a konverterben van valami automatika, ami tönkreteszi a jelet, akkor tud esetleg valaki minőségibb kompozit->hdmi vagy kompozit->vga konvertert ajánlani?

2. probléma:

A zx net nagyjából műdödik, a spectrumhoz eredetileg mellékelt kazetta mono jack kábelt használom hozzá.
Itt azt a furcsaságot tapasztalom, hogy teljesen véletlenszerűen az egyik gép hol érzékeli, hol meg nem, hogy hálózaton lenne.
Ha kiadom a SAVE *"n";0 parancsot, akkor elméletileg ki kellene küldenie az aktuális basic programot broadcast üzemmódban függetlenül attól, hogy kap-e visszajelzést a hálózatról. Az egyik gép így is tesz.
A másik viszont hol kiküldi rendesen, hol meg csak vár és vár a fekete borderrel és csak caps+break-el lehet leállítani. Ha a jack kábel be van kötve a másik gépbe, de az nincs bekapcsolva, akkor a parancs lefut, ahogy kell. De ha kihúzom a kábelt, akkor beáll a várakozó üzemmód, ha pedig bekapcsolom a másik gépet, akkor hol megy, hol meg nem.
Néha meg működik elsőre rendesen, ahogy kell.
Egyszerűen nem tudok rájönni, hogy mi okozza a hibát. Már ha egyáltalán hiba és nem valami ismeretlen tulajdonsága a zx net-nek (elég minimális a fellelhető dokumentáció).
Próbáltam már mindent:
- station numbert állítgattam mindkét gépen
- végig próbáltam az összes kábel csatlakozás kombinációt
- próbáltam különböző sorrendben bekapcsolni a gépeket
- néha ha kihúzom a jack dugót és visszatolom, akkor működik, máskor nem segít
- néha gép újraindítás után megy, de nem mindig

Nagyon megköszönném, ha valaki elmagyarázná, hogyan lehet üzembizotsan felállítani a zx netet, vagy nyugtasson meg, hogy ez már csak ilyen, esetleg hardveres hiba lehet a dolog mögött.

Üdv,

kpbendi

csaba
Alapító tag
Hozzászólások: 332
Csatlakozott: 2012.01.09. 19:18
Rádióamatőr hívójel: HG5BMU
Tartózkodási hely: Surány
Kapcsolat:

Re: Saját ZX Net

Hozzászólás Szerző: csaba » 2020.08.10. 14:35

nekem a vga-féléből kettő is, eddig nem tűnt fel ilyen jelenség
tehát a border változtatására változik a paper terület fényereje is.
ez tipikus videójel dc szint helyreállítási probléma, este kipróbálom

kipróbáltam, nem változik a fényerő

csaba
Alapító tag
Hozzászólások: 332
Csatlakozott: 2012.01.09. 19:18
Rádióamatőr hívójel: HG5BMU
Tartózkodási hely: Surány
Kapcsolat:

Re: Saját ZX Net

Hozzászólás Szerző: csaba » 2020.08.10. 21:51

A "composite mod, video tranzisztorok" mit takarnak pontosan, mert simán okozhatnak ilyesmit
Én a videojel kimenetet legegyszerűbben a modulátor bemenetéről veszem, mindenféle hókuszpókusz nélkül.

kpbendi
Hozzászólások: 79
Csatlakozott: 2012.01.09. 14:42

Re: Saját ZX Net

Hozzászólás Szerző: kpbendi » 2020.08.14. 09:27

Először én is direktben a modulátor bemenetét használtam kompozit kimenetnek, de a gép összes kondijának lecserélése után is nagyon zajos maradt a jel, így először beraktam egy 100mf kondenzátort, ami valamennyit javított a helyzeten, de nem eleget, így kicseréltem a TR1 és TR2 tranzisztorokat BC549C-re, az eredetikhez képest 180 fokban elfordítva ez alapján:

http://blog.retroleum.co.uk/electronics ... ideo-mods/
(lásd: 7. pont)

Ez tényleg jelentősen javított a jel minőségen, de ezek szerint a tranzisztorok lecserélése a border fényességétől függően belematat a dc szintbe is, csak normál monitoron nem tűnt fel.

Avatar
Bali
Alapító tag
Hozzászólások: 2452
Csatlakozott: 2012.01.06. 13:34
Tartózkodási hely: Budapest III.
Kapcsolat:

Re: Saját ZX Net

Hozzászólás Szerző: Bali » 2020.08.15. 21:44

A két ZX Interface 1 egyforma verziójú? Ezekből is volt több issue...
-= Bali =-
(c) 1983-2017 Evil-Soft

csaba
Alapító tag
Hozzászólások: 332
Csatlakozott: 2012.01.09. 19:18
Rádióamatőr hívójel: HG5BMU
Tartózkodási hely: Surány
Kapcsolat:

Re: Saját ZX Net

Hozzászólás Szerző: csaba » 2020.08.17. 07:53

"ezek szerint a tranzisztorok lecserélése a border fényességétől függően belematat a dc szintbe"

a gépben a világosság jel az ula-tól DC csatolásban jut a modulátorig(amíg be nem építed a leírás szerinti 100u kondit), a munkapontok változtatására(tranzisztor csere miatt) szélsőséges esetben a jel alja vagy teteje vágva lesz, vagy arányaik eltorzulnak.
a képtartalomtól függő fényerő változás valahol egy AC csatolás miatt lehet, ha utána a monitorban a szintrögzítés nem működik megfelelően.
A szintrögzítés hibás működése(a monitorban) viszont lehet az elállítódott munkapontok(TR cserék) miatt torzult videójel miatt.
Meg kellene nézni oszcilloszkóppal TR1-2 kivezetésein a jelalakokat, munkapontot.

A video jel zajosságát leggyakrabban a 12v-on levő két kondi kiszáradása szokta okozni.

kpbendi
Hozzászólások: 79
Csatlakozott: 2012.01.09. 14:42

Re: Saját ZX Net

Hozzászólás Szerző: kpbendi » 2020.08.17. 20:16

Bali írta:
2020.08.15. 21:44
A két ZX Interface 1 egyforma verziójú? Ezekből is volt több issue...
Megnéztem a

Kód: Egész kijelölése

close#0: print peek 23729

paranccsal és két különböző verzió, az egyik issue 1, a másik issue 2. (Legalábbis a ROM.)
Érdekes módon az issue 2-vel van gond.

kpbendi
Hozzászólások: 79
Csatlakozott: 2012.01.09. 14:42

Re: Saját ZX Net

Hozzászólás Szerző: kpbendi » 2020.08.17. 20:18

csaba írta:
2020.08.17. 07:53
"ezek szerint a tranzisztorok lecserélése a border fényességétől függően belematat a dc szintbe"

a gépben a világosság jel az ula-tól DC csatolásban jut a modulátorig(amíg be nem építed a leírás szerinti 100u kondit), a munkapontok változtatására(tranzisztor csere miatt) szélsőséges esetben a jel alja vagy teteje vágva lesz, vagy arányaik eltorzulnak.
a képtartalomtól függő fényerő változás valahol egy AC csatolás miatt lehet, ha utána a monitorban a szintrögzítés nem működik megfelelően.
A szintrögzítés hibás működése(a monitorban) viszont lehet az elállítódott munkapontok(TR cserék) miatt torzult videójel miatt.
Meg kellene nézni oszcilloszkóppal TR1-2 kivezetésein a jelalakokat, munkapontot.

A video jel zajosságát leggyakrabban a 12v-on levő két kondi kiszáradása szokta okozni.

Köszi a tanácsot, amint lesz időm megnézem szkóppal.
Amúgy az összes elektrolit kondit kicseréltem, így valószínűleg nem azokkal volt a gond.

csaba
Alapító tag
Hozzászólások: 332
Csatlakozott: 2012.01.09. 19:18
Rádióamatőr hívójel: HG5BMU
Tartózkodási hely: Surány
Kapcsolat:

Re: Saját ZX Net

Hozzászólás Szerző: csaba » 2020.10.28. 14:00

összeraktam a két gépes hálózatot, két issue2 interfésszel
kis rövid programmal broadcastban küldöm ki a képernyőt, majd törlöm és screen vételre kapcsolom
a másik gépen a vétel után kiküldöm, törlöm, és így tovább oda vissza rendben másolgatja a képernyőt a végtelenségig.
a fenti peek mindkettőnél 80-at ad eredményül

Válasz küldése

Vissza: “ZX Spectrum”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég