Spectrum 48 LOAD nem megy

Mindenféle Sinclair gép hibajelenségei, javítási módszerei
Avatar
Bali
Site Admin
Hozzászólások: 1753
Csatlakozott: 2012.01.06. 13:34
Tartózkodási hely: Budapest III.
Kapcsolat:

Spectrum 48 LOAD nem megy

Hozzászólás Szerző: Bali » 2017.10.01. 23:51

Van egy olyan jelenség amikor a gép bemelegedése után bizonytalanul vagy egyáltalán nem lehet a jack bemeneten programot betölteni. Ezt egy ULA hiba okozza. Épp zka-val messengereztem az imént és valahogy szóba került. Miután megoldása is van rá ULA csere nélkül, így át is adom neki a szót. :)
-= Bali =-
(c) 1983-2017 Evil-Soft

zka
Speccyalista
Hozzászólások: 11
Csatlakozott: 2017.09.26. 23:22

Re: Spectrum 48 LOAD nem megy

Hozzászólás Szerző: zka » 2017.10.02. 00:20

Sziasztok, igen, nálam is járt már két gép is, aminek az ULA MIC/TAPE bemenete (28-as láb) zárlatos lett valamiért, és egyáltalán nem töltött. Szkópon megnézve a jelet, látszott, hogy alig marad valami a bejövő jelből a lábon. Az általam elkövetett javítás a következőkből állt: átkötöttem a bemeneten a C32 100nF-os kondit, ekkor már szépen töltött a Z80TAPE-ról. Hagyományos magnóval nem próbáltam, mert nincs. A jelszintet meg kellett emelnem 2.5V-ra (normálisan 2.0V elég a spectrumoknak). Hang viszont nincs, mert nagyon kis jelet ad ki az ULA a zárlatos lábán. Ezt egy komparátorral oldottam meg, az egyik lábára kb. 0.6V-os egyenfeszt kell adni, a másikra pedig mehet az ULA lába közvetlenül, dióda nélkül. A komparátor kimenetével egy tranzisztoton át hajtottam meg a speakert. Segítségül mellékeltem néhány ábrát. Ha bárkinek kérdése van, bátran írjon. Remélem hasznos volt a hozzászólásom :)

Szerk: a kapcsolási rajzok az ISSUE2 és az ISSUE3..6 modelleken tartalmazzák az átkötéseket és a kiszedendő alkatrészeket. A C32-es kondi minden modellben ugyan ott van, van amelyikben rálóg a hűtőborda, ezt ne felejtsétek el visszacsavarozni rendesen a szerelés után. Javaslom a hátoldalon az átkötést, jóval egyszerűbb. A speaker helyett buzzer került a komparátoros kapcsrajzra, ezt nézzétek el nekem. A kompatáror és a tranzisztor elfér egy pici kis öcsipanelen, próbanyákon.

Üdv.
Zoli
Csatolmányok
SPEAKER.png
LAYOUT C32.png
ISSUE3+ C32.png
ISSUE2 C32.png

csaba
Speccyalista
Hozzászólások: 158
Csatlakozott: 2012.01.09. 19:18
Rádióamatőr hívójel: HG5BMU
Tartózkodási hely: Surány
Kapcsolat:

Re: Spectrum 48 LOAD nem megy

Hozzászólás Szerző: csaba » 2017.10.04. 10:08

Jó ötlet analóg oldalról megúszni az ULA cserét, viszont ha már öcsipanel akkor egy műveleti erősítővel lehetne párszoros erősítést tenni a bemenetre, így kevesebb jelszint is elegendő.
A hangkártyák vonal kimenetének, vagy anno a walkman-eknek alapból sem volt mindig elegendő a kimeneti jelszintjük.

Avatar
Bali
Site Admin
Hozzászólások: 1753
Csatlakozott: 2012.01.06. 13:34
Tartózkodási hely: Budapest III.
Kapcsolat:

Re: Spectrum 48 LOAD nem megy

Hozzászólás Szerző: Bali » 2017.10.12. 22:08

Közben diskuráltam még másokkal is és ez a probléma gyakoribb, mint ahogy ezt én gondoltam, lehet, hogy akár készíthetnénk hozzá nyákot is. Vélemény?
-= Bali =-
(c) 1983-2017 Evil-Soft

csaba
Speccyalista
Hozzászólások: 158
Csatlakozott: 2012.01.09. 19:18
Rádióamatőr hívójel: HG5BMU
Tartózkodási hely: Surány
Kapcsolat:

Re: Spectrum 48 LOAD nem megy

Hozzászólás Szerző: csaba » 2017.10.13. 09:32

Esetleg a hibás áramköri rész javítgatása helyett, egyből digitálisan a cpu bus-ra kapcsolódni egy uj ki-bemeneti illesztővel.
A töltés oldalon jóval korrektebb illesztést lehet csinálni.
pl. az egyik ula klónban így néz ki:
ula2.JPG
ula1.JPG

Válasz küldése

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég